Seite drucken | Fenster schließen

Bilder über bildercache einfügen (nicht so gut wie direkt im Forum hochladen)

Gedruckt von: Tropenland
Kategorie: Community
Forumname: Fotos
Beschreibung: Hier könnt Ihr eure Pflanzenfotos zeigen
URL: http://www.tropenland.at/forum/forum_posts.asp?TID=10549
Druckdatum: 03-Apr-2020 um 23:20


Thema: Bilder über bildercache einfügen (nicht so gut wie direkt im Forum hochladen)
Erstellt von: Phlashbugher
Betreff: Bilder über bildercache einfügen (nicht so gut wie direkt im Forum hochladen)
Erstelldatum: 25-Nov-2009 um 17:51
Hallo allerseits!

Da es hier neuerdings öfter mal dazu kommt, dass Bilder falsch eingefügt werden, so dass sie nicht anklickbar sind, oder beim Anklicken nur den gleichen Artikel nochmal zeigen anstatt des vergrößerten Bildes, mach ich jetzt mal eine Komplett-Anleitung, wie man das am besten bewerkstelligt.

Die meisten schaffen es noch, das Bild auf bildercache.de hochzuladen (falls es einer doch nicht hin bekommt, hier steht wie's geht). Danach geht aber oft etwas schief, sei es durch Verwendung des falschen Codes, falsches Einfügen des Codes, oder Verwendung des Microsoft Internet Explorer (und seiner automatischen Link-Erzeugung). Deshalb hier die notwendigen Schritte, ausführlich und hoffentlich trotzdem übersichtlich.

Finden des richtigen Codes:
Nach dem erfolgreichen Hochladen des Bildes auf bildercache.de findet man eine Liste mit Forencodes zur Einbindung des Bildes. Hier entscheidet man sich am besten für eins derer, wo "Alternative" dahinter steht. Diese sehen ungefähr so aus:
[URL=http://www.bildercache.de/anzeige.html?dateiname=19991231-235959-123.jpg][IMG]http://www.bildercache.de/thumbnail/19991231-235959-123.jpg[/IMG][/URL]
Wichtig ist vor allem, dass der Code mit [URL=http:// beginnt und mit [/URL] endet (was man aber erst sieht, wenn man rein klickt und den Eingabe-Cursor ganz bis ans Ende bewegt). Faustregel hierbei ist: Wenn irgendwo Gänsefüßchen (") drin sind, ist es der falsche Code!
Sollte man das Bild in niedriger Auflösung hochgeladen haben (320x240 oder so), bekommt man auch einen Code angezeigt, mit dem das Bild direkt eingebunden werden kann. Der heißt dann "Bild für Foren" und fängt mit [IMG] an. Diesen kann man auch verwenden, das Bild erscheint dann gleich in der vollen Größe im Beitrag. Dieser Code steht aber nicht zur Verfügung, wenn das Bild zu groß ist.

Richtiges Kopieren und Einfügen:
Zunächst klickt man auf den richtigen Code drauf, wobei die Schrift markiert wird (der Hintergrund wird dann blau).
Leute, die gern mal die Tastatur benutzen, drücken dann die STRG-Taste (oder die Leute mit englischer Tastatur die CTRL-Taste), hält sie gedrückt, und betätigt dann die Taste "c". Danach kann man beide Tasten wieder loslassen. Einfügen geht genau so, aber mit den Tasten STRG + "v". Es wird dann an die Stelle eingefügt, wo sich die Eingabemarke befindet, also sollte man vorher in den Text klicken, wo man das Bild später haben möchte.
Leute, die lieber mit der Maus arbeiten, klicken stattdessen mit der rechten Maustaste auf den Code, der zuvor wie oben beschrieben markiert wurde, woraufhin ein Menü aufgeht. Dieses muss den Menüpunkt "Kopieren" enthalten, den man auch gleich mit der linken Maustaste anklickt. Zum Einfügen bewegt man die Maus an die Stelle, an der man einfügen möchte, und öffnet wieder mit einem Klick auf die rechte Maustaste das Kontextmenü. Dort klickt man dann aber stattdessen auf "Einfügen".
In allen Fällen darf man zum Einfügen nicht den Button "Bild einfügen" verwenden! Das Bild (bzw. der Link dazu) wird mit den Ersetzungscodes [IMG] bzw. [URL] eingefügt. Diese sind im Code schon enthalten, deshalb muss einfach der Code als Text an die Stelle eingefügt werden, wo später das Bild angezeigt werden soll. Das Bild ist auch zunächst gar nicht sichtbar, sondern es wird nur der Code als einfacher Text angezeigt.

Austricksen des Internet Explorer:
(Leute die den Firefox oder Safari oder Chrome als Browser benutzen, brauchen das hier nicht zu lesen. Diese Browser müssen nicht ausgetrickst werden.)
Der Microsoft Internet-Explorer möchte es gern dem Benutzer möglichst einfach machen, und macht aus allen Textpassagen, die mit http:// beginnen, einen anklickbaren Link. Das mag auch manchmal durchaus nützlich sein, da man dann nichts über HTML oder Forencodes wissen muss und trotzdem einen anklickbaren Link erzeugen kann. Leider setzt er den Benutzer aber nicht darüber in Kenntnis, dass er den Text, der gerade geschrieben oder eingefügt wurde, eigenmächtig verändert hat. Das wäre aber durchaus angebracht, denn manchmal ist dieses Verhalten gar nicht gut.
Beim Einfügen des Foren-Codes wird nämlich ebenfalls ein anklickbarer Link erzeugt, obwohl schon durch den Code selbst ein Link erzeugt werden sollte. Leider zerstört dieser "Link im Link" aber die Funktionalität des Foren-Codes, so dass unerwartete Dinge passieren (z.B. können Teile des Forencodes im Text auftauchen, falsche Adressen verlinkt werden oder ähnliches).
Leider lässt sich dieses Verhalten aber nicht abstellen, da Microsoft leider versäumt hat, dieses "Feature" in den Einstellungen zu erwähnen. Wir müssen also lernen, zu erkennen, wenn der Internet-Explorer uns in die Suppe spuckt. Glücklicherweise geht das auch, denn der automatisch eingefügte Link hat eine andere Farbe als "normaler" Text, und die ändert sich sogar, wenn man mit dem Mauszeiger drüber fährt. Z.B. könnte der Forencode von oben nach dem Einfügen im Internet-Explorer so aussehen:
[URL=http://www.bildercache.de/anzeige.html?dateiname=19991231-235959-123.jpg][IMG]http://www.bildercache.de/thumbnail/19991231-235959-123.jpg[/IMG][/URL]
Man muss jetzt den automatisch erzeugten Link innerhalb des Foren-Codes von Hand entfernen. Dazu positioniert man die Eingabe-Marke an die Position direkt hinter den blauen Text (also beispielsweise hier direkt zwischen das /URL und das letzte ] ) und drückt danach die Rückschritt-Taste (Backspace), so als wolle man das letzte Zeichen entfernen. Stattdessen sollte aber nur der automatisch erzeugte Link entfernt werden, erkennbar an der schwarz werdenden Schrift. Das macht man an allen Stellen, wo man blaue Schrift findet, die sich beim Draufzeigen mit der Maus nach rot verfärbt (es sei denn, man möchte diesen Link absichtlich haben).
Neuere Versionen des Internet-Explorer scheinen das nur noch dann zu machen, wenn man einen falschen Foren-Code benutzt (einen mit " drin), aber man weiß ja nie. Sicherheitshalber sollte man es überprüfen: Innerhalb von Forencodes darf kein farbiger Text auftauchen, erst recht nicht, wenn er sich beim Draufzeigen mit der Maus verfärbt!

Ersetzungscodes zulassen:

Vor dem Abschicken des Beitrages unbedingt kontrollieren, dass unter dem Eingabefenster ein Häkchen bei "Zulassen Ersetzungscodes Beitrag zu formatieren" gesetzt ist. Ansonsten hat man nämlich die ganzen [URL]- und [IMG]-Codes noch als Text im Beitrag stehen, wo doch anklickbare Bilder so viel schöner sind...

Abschließende Kontrolle:
Hat man seinen Beitrag geschrieben und alle Bilder eingefügt (wobei man natürlich alle obigen Hinweise beachtet hat), möchte man vielleicht kontrollieren, ob das Ergebnis so aussieht und sich so verhält, wie man das beabsichtigt hat. Normalerweise sieht man das Ergebnis erst, wenn man den Beitrag ans Forum schickt, aber wenn dann noch was falsch ist, ist es falsch im Forum.
Damit das nicht passiert, gibt es die Vorschau (der mittlere der untersten drei Buttons). Sie zeigt den Beitrag in einem separaten Fenster so an, als sei er schon an das Forum gesendet worden. Man kann dann kontrollieren, ob alle Bilder richtig aussehen und ob alle Links richtig sind. Wenn man alles nochmal kontrolliert hat, kann man den Beitrag relativ gefahrlos abschicken, ohne hinterher unliebsame Überraschungen zu erleben.

Ich hoffe, das hilft einigen Leuten, vor allem Neulingen. Für die Leute, die schon kaputte Bilder in ihren Beiträgen verwendet haben, schreib ich bei Gelegenheit noch mal einen Beitrag, wie man das selbst reparieren kann. Das wird aber viel komplizierter, um es gleich vorweg zu sagen. Lieber ordentlich machen und dann kontrollieren, man erspart sich wirklich viel Ärger.

Viel Erfolg,
Phlashbugher


Update: Wie versprochen, ist der Artikel zur Reparatur von Bildern in bestehenden Beiträgen jetzt
hier verfügbar.


-------------
Phantasie ist wichtiger als Wissen, denn Wissen ist begrenzt. (Albert Einstein)



Antworten:
Erstellt von: Mirii
Erstelldatum: 25-Nov-2009 um 18:17
Danke Wink

-------------
Solange Menschen denken,
dass Tiere nicht fühlen,
solange müssen Tiere fühlen,
dass Menschen nicht denken.


Erstellt von: Kentia
Erstelldatum: 20-Jul-2012 um 12:14
Meine Güte - jetzt kann ich nicht nur Links verstecken, sondern auch meine Bilder richtig da einfügen, wo ich sie hinhaben will, nachdem ich in meinen Einstellungen Den Windows IE 5 + WYSIWYG Editor verwenden ausgeschaltet habe ! Ich habe schon an meinem Geisteszustand gezweifelt ...

-------------
Herzlichst Babs





Seite drucken | Fenster schließen